<!DOCTYPE html><html lang="en-US" itemscope itemtype="http://schema.org/Article"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no"><title>Domino&#39;s Now Offers a Baby Registry | Extra Crispy</title><meta name="description" content="Welcoming a child into the world is daunting. The sleepless nights and the range of expenditures can take a toll on new parents. Thankfully, one new bab..."><meta name="keywords" content="breakfast, brunch, food, food news, eggs, coffee, bacon, morning culture, cooking hacks, recipe hacks, pancakes, waffles, cereal, recipe ideas, breakfast ideas, brunch ideas, cooking breakfast, cafe culture"><meta name="news_keywords" content="breakfast, brunch, food, food news, eggs, coffee, bacon, morning culture, cooking hacks, recipe hacks, pancakes, waffles, cereal, recipe ideas, breakfast ideas, brunch ideas, cooking breakfast, cafe culture"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@extracrispy"><meta name="p:domain_verify" content="014366745e9b889c962b312f25007c9c"/><meta property="fb:pages" content="875710779209860"><meta property="og:locale" content="en_US"><meta property="og:site_name" content="Extra Crispy"><meta property="og:type" content="article"><meta property="og:title" content="Domino&#39;s Now Offers a Baby Registry"><meta property="og:description" content="No word on whether or not you can use their pizza tracker to monitor your pregnancy"><meta property="og:image" content="https://timedotcom.files.wordpress.com/2017/11/dominos-pizza-baby-shower.jpg?quality=85"><meta property="og:image:width" content="1024"><meta property="og:image:height" content="614"><meta name="author" content="Tim Nelson"><meta property="article:author" content="Tim Nelson"><meta property="article:publisher" content="https://www.facebook.com/extracrispy"><meta property="article:published_time" content="2017-11-30"><meta property="article:section" content="Culture"><meta property="article:tag" content="Fast Food"><meta property="article:tag" content="News"><meta property="og:url" content="http://www.extracrispy.com/culture/4492/dominos-now-offers-a-baby-registry"><link rel="canonical" href="http://www.extracrispy.com/culture/4492/dominos-now-offers-a-baby-registry"><link rel="amphtml" href="http://amp.timeinc.net/extracrispy/culture/4492/dominos-now-offers-a-baby-registry?source=dam"><link rel="stylesheet" href="https://d1m8bioeteo0b4.cloudfront.net/prod/styles.css?v=351d8c4"><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:400,700|Fugaz+One"><link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-57x57.png"><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-114x114.png"><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-72x72.png"><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-144x144.png"><link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-60x60.png"><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-120x120.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="/https://d1m8bioeteo0b4.cloudfront.netapple-touch-icon-76x76.png"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-96x96.png" sizes="96x96"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-32x32.png" sizes="32x32"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-16x16.png" sizes="16x16"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-128.png" sizes="128x128"><meta name="application-name" content="Extra Crispy"><meta name="msapplication-TileColor" content="#FFE240"><meta name="msapplication-TileImage" content="https://d1m8bioeteo0b4.cloudfront.net/mstile-144x144.png"><meta name="msapplication-square70x70logo" content="https://d1m8bioeteo0b4.cloudfront.net/mstile-70x70.png"><meta itemprop="keywords" content="breakfast, brunch, food, food news, eggs, coffee, bacon, morning culture, cooking hacks, recipe hacks, pancakes, waffles, cereal, recipe ideas, breakfast ideas, brunch ideas, cooking breakfast, cafe culture"><meta itemprop="description" content="Welcoming a child into the world is daunting. The sleepless nights and the range of expenditures can take a toll on new parents. Thankfully, one new bab..."><meta itemprop="url" content="http://www.extracrispy.com/culture/4492/dominos-now-offers-a-baby-registry"><span itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.extracrispy.com/images/site-logo.png"></span><meta itemprop="name" content="Extra Crispy"><meta itemprop="url" content="http://www.extracrispy.com"></span><span itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://timedotcom.files.wordpress.com/2017/11/dominos-pizza-baby-shower.jpg?quality=85"><meta itemprop="height" content="100%"><meta itemprop="width" content="100%"></span><meta itemprop="author" content="Tim Nelson"><script>var adSlotTargets = {};var adParams = {"ptype" : "content","zone" : "Culture".replace(/\(|\)/g, '').replace(/\s+/g, '-').toLowerCase(),"ch" : "Culture".replace(/\(|\)/g, '').replace(/\s+/g, '-').toLowerCase(),"sch" : "Fast Food,News".replace(/\(|\)/g, '').replace(/, /g, ',').replace(/\s+/g, '-').toLowerCase().split(',')};adSlotTargets.ptype = adParams.ptype;adSlotTargets.ch = adParams.ch;adSlotTargets.aid = "4492";adSlotTargets.ctype = "article";if (adSlotTargets.ctype === "video" || adSlotTargets.ctype === "gallery") {adSlotTargets.etype = adSlotTargets.ctype;}adSlotTargets.sch = adParams.sch;if (adParams.ptype === "channel" && adParams.zone !== "homepage") {adParams.zone += "/main";adSlotTargets.ptype = "channel";adSlotTargets.ctype = "main";};var TIA_CONFIG = {setGlobalTargeting: adSlotTargets,sitename: "extracrispy",zone: adParams.zone,realvu: true};window.time_dfp = window.time_dfp || [];window.time_dfp.push(function() {window.time_dfp.init(TIA_CONFIG);});</script><script type="text/javascript">__reach_config = {pid: '5734de2b736b79b1e9001a74',title: 'Domino\'s Now Offers a Baby Registry',url: 'http://www.extracrispy.com/culture/4492/dominos-now-offers-a-baby-registry',date: '2017-11-30',authors: ['Tim Nelson'],channels: ['Culture'],tags: "Fast Food,News".split(","),ignore_errors: false};(function(){var s = document.createElement('script');s.async = true;s.type = 'text/javascript';s.src = document.location.protocol + '//d8rk54i4mohrb.cloudfront.net/js/reach.js';(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(s);})();</script><script type="text/javascript">var _sf_async_config = _sf_async_config || {};/** CONFIGURATION START **/_sf_async_config.uid = 63293;// ACCOUNT NUMBER_sf_async_config.domain = extracrispy.com;// DOMAIN_sf_async_config.flickerControl = false;_sf_async_config.useCanonical = true;/** CONFIGURATION END **/var _sf_startpt = (new Date()).getTime();</script><script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script><script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod? n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '1545947199043709');fbq('track', "PageView");</script><noscript><img height="1" width="1" style="display:none"src="https://www.facebook.com/tr?id=1545947199043709&ev=PageView&noscript=1"/></noscript><!-- Time Inc - Segment --><script type="text/javascript">!function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","reset","group","track","ready","alias","debug","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="4.0.0";analytics.load("YYHbYKtAgp7bXHASvGPebuFmlNI0Z2ME");window.segment = {"contentAuthorName":"Tim Nelson","contentCmsCategory":"Culture","contentCmsId":"4492","contentCmsSubCategory":"fast food|news","contentCmsTerms":["Culture","fast food","news"],"contentCmsTags":null,"contentContributorName":null,"contentFeaturedImage":"https://timedotcom.files.wordpress.com/2017/11/dominos-pizza-baby-shower.jpg?quality=85","contentHeadline":"Domino's Now Offers a Baby Registry","contentModifiedDate":"2017-11-30T17:08:07Z","contentPublishedDate":"2017-11-30T17:08:07Z","contentSearchTerm":null,"contentShownOnPlatform":"own","contentType":"article","numberofSearchResult":null,"path":"/culture/4492/dominos-now-offers-a-baby-registry","search":null,"timeIncApplication":"wordpress","timeIncBrand":"extracrispy.com","title":"Domino's Now Offers a Baby Registry","url":"http://www.extracrispy.com/culture/4492/dominos-now-offers-a-baby-registry"};window.analytics.page(window.segment);}}();</script></head><body class="bg-food" style="background-image: url('https://d1m8bioeteo0b4.cloudfront.net/images/bg-food-left-1.jpg'), url('https://d1m8bioeteo0b4.cloudfront.net/images/bg-food-right-3.jpg')"><script type="text/javascript">var siteDisplayFormat = "mobile";window.viewportWidth = Math.max(document.documentElement.clientWidth, window.innerWidth || 0);if (window.viewportWidth > 840)  {siteDisplayFormat = "desktop";}var utag_data = {channel: "extracrispy",page_name: "Domino&#39;s Now Offers a Baby Registry".replace(/&[\S]{0,7};/ig, ""),site_display_format: siteDisplayFormat,template_type: "article",site_section1: "Culture",};utag_data.site_section2 = "Fast Food";utag_data.content_id = "4492";utag_data.author_name = "Tim Nelson";utag_data.publish_date = "2017-11-30";</script><script type="text/javascript">(function(a,b,c,d){a='//tags.tiqcdn.com/utag/timeinc/extracrispy.com/prod/utag.js';b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);})();</script><header id="js-site-header" class="site-header"><div class="flex flex--no-wrap flex--stretch flex--middle container"><a class="site-header__logo" href="/"><img class="site-nav__logo" src="/images/site-logo.png" width="140" height="85" alt="Extra Crispy"></a><div class="responsive-spacer"></div><div class="responsive-nav-toggle js-dropdown"><span class="responsive-nav-toggle__text">Menu</span><i class="icon icon-dropdown dropdown-icon"></i><nav class="responsive-nav dropdown-popout"><div class="responsive-nav__arrow"></div><div class="responsive-nav__wrapper"><ul class="site-nav"><li class="site-nav__item"><a class="site-nav__link" href="/culture">Culture</a></li><li class="site-nav__item"><a class="site-nav__link" href="/drinks">Drinks</a></li><li class="site-nav__item"><a class="site-nav__link" href="/food">Food</a></li><li class="site-nav__item"><a class="site-nav__link" href="/video">Video</a></li><li class="site-nav__dropdown-toggle site-nav__item js-dropdown"><i class="icon icon-dropdown dropdown-icon"></i><ul class="site-nav__dropdown dropdown-popout"><div class="site-nav__dropdown-arrow"></div><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/recipes">Recipes</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/news">News</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/bacon">Bacon</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/travel">Travel</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/cheese">Cheese</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/butter">Butter</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/booze">Booze</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/coffee">Coffee</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/eggs">Eggs</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/rankings">Rankings</a></li></ul></li></ul><ul class="site-social"><li class="site-social__item"><a class="site-social__newsletter" href="/newsletter" target="_blank">Newsletter Signup</a></li><li class="site-social__item"><a class="icon icon-facebook" href="https://www.facebook.com/extracrispy" title="Facebook" aria-label="Facebook" target="_blank"></a><a class="icon icon-twitter" href="https://www.twitter.com/extracrispy" title="Twitter" aria-label="Twitter" target="_blank"></a><a class="icon icon-instagram" href="https://www.instagram.com/extracrispy" title="Instagram" aria-label="Instagram" target="_blank"></a><a class="icon icon-pinterest" href="https://www.pinterest.com/itsextracrispy" title="Pinterest" aria-label="Pinterest" target="_blank"></a></li></ul></div></nav></div><form class="js-search site-search" action="\search" method="GET"><label for="search" class="u-off-screen">Search</label><input id="search" class="js-search-input site-search__input" type="text" name="q" placeholder="Search"><button class="js-search-toggle site-search__submit button icon icon-search" type="submit" title="Submit" aria-label="Submit"></button></form></div></header><main><article itemprop="mainEntityOfPage"><header class="article-header "><div class="article-header__hero-image " style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=1920&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F11%2Fdominos-pizza-baby-shower.jpg%3Fquality%3D85');"></div><div class="article-header__overlay"><div class="article-header__flex container"><div class="article-header__hero-credit">illustration by lauren kolm</div><div class="article-header__pinterest-wrapper"><a class="js-tealium-social-share pinterest-pin-it-button icon icon-pinterest"href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fextra.cr%2F2zPUk6n&amp;description=Domino&#39;s%20Now%20Offers%20a%20Baby%20Registry&amp;media=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F11%2Fdominos-pizza-baby-shower.jpg%3Fquality%3D85"data-social="pinterest"data-pin-do="buttonPin"data-pin-custom="true"target="_blank"rel="nofollow"title="Share on Pinterest"aria-label="Share on Pinterest"></a></div><div class="article-header__hero-text"><h1 class="article-header__title brush-fill brush-fill--white" itemprop="headline">Domino&rsquo;s Now Offers a Baby Registry</h1><p class="article-header__subtitle brush-fill brush-fill--black">No word on whether or not you can use their pizza tracker to monitor your pregnancy</p></div></div></div></header><div class="container flex" id="js-sticky-ad-container"><section class="container__main flex-item"><div class="article-meta"><a class="article-meta__author" href="/author/tim-nelson">Tim Nelson</a> <time class="article-meta__date" datetime="2017-11-30" itemprop="datePublished">November 30, 2017</time><span content="November 30, 2017" itemprop="dateModified"></span><ul class="article-meta__categories"><li class="article-meta__category category-tag"><a class="brush-stroke brush-stroke--yellow" href="/culture">Culture</a></li><li class="article-meta__category category-tag"><a class="brush-stroke brush-stroke--yellow" href="/fast-food">Fast Food</a></li><li class="article-meta__category category-tag"><a class="brush-stroke brush-stroke--yellow" href="/news">News</a></li></ul><ul class="article-meta__socials"><li class="article-meta__social"><a class="js-tealium-social-share icon icon-twitter"data-social="twitter"href="http://twitter.com/intent/tweet?text=Domino&#39;s%20Now%20Offers%20a%20Baby%20Registry&amp;via=extracrispy&amp;url=http%3A%2F%2Fextra.cr%2F2zSddG1"target="_blank" rel="nofollow"title="Share on Twitter" aria-label="Share on Twitter"></a></li><li class="article-meta__social"><a class="js-tealium-social-share icon icon-facebook"data-social="facebook"href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fextra.cr%2F2zSzPWZ"target="_blank" rel="nofollow"title="Share on Facebook" aria-label="Share on Facebook"></a></li><li class="article-meta__social"><a class="js-tealium-social-share icon icon-pinterest"data-social="pinterest"data-pin-do="buttonPin"data-pin-custom="true"href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fextra.cr%2F2zPUk6n&amp;description=Domino&#39;s%20Now%20Offers%20a%20Baby%20Registry&amp;media=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F11%2Fdominos-pizza-baby-shower.jpg%3Fquality%3D85"target="_blank" rel="nofollow"title="Share on Pinterest" aria-label="Share on Pinterest"></a></li><li class="article-meta__social"><a class="icon icon-email"href="mailto:?subject=Dominos%20Now%20Offers%20a%20Baby%20Registry&amp;body=http://www.extracrispy.com/culture/4492/dominos-now-offers-a-baby-registry?xid=emailshare"target="_blank" rel="nofollow"title="Share via Email" aria-label="Share via Email"></a></li></ul></div><div class="article-body" itemprop="articleBody"><p>Welcoming a child into the world is daunting. The sleepless nights and the range of expenditures can take a toll on new parents. Thankfully, one new baby registry is here to help, and it makes use of one thing that we already know solves everything: pizza.&nbsp;</p><p>That’s right. Aptly arriving nine months after the launch of their wedding registry, expectant moms and dads can now <a href="http://dominosbabyregistry.com/" rel="noopener noreferrer" target="_blank">register at Domino’s for all their baby needs</a>. Conceived (sorry) in partnership with baby registry company <a href="https://www.guguguru.com/" rel="noopener noreferrer" target="_blank">Gugu Guru</a>, it’s an effort to break away from traditional registry in favor of what parents <em>really</em> want. “While new parents are focusing on their tiny special delivery, Domino’s will focus on delivering great pizza for dinner, or lunch, or late-night feedings,” said Jenny Fouracre, director of the pizza chain’s PR.&nbsp;</p><aside class="related-content"><ul class="related-content__list flex flex--no-wrap"><li class="related-content__item flex-item"><div class="ad native-ad" data-ad-type="nativeAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></li><li class="related-content__item flex-item"><div class="related-content__title"><a href="/food/4480/pizza-hut-to-launch-vegan-options-in-the-uk" >Pizza Hut to Launch Vegan Options in the UK</a></div><div class="related-content__author">By <a class="u-plain-link" href="/author/tim-nelson">Tim Nelson</a></div><div class="related-content__channel">Posted in <a href="/food">Food</a></div></li><li class="related-content__item flex-item"><div class="related-content__title"><a href="/food/3661/papa-johns-gluten-free-pizza-actually-has-gluten-in-it" >Papa John&#039;s Gluten-Free Pizza Actually Has Gluten In It</a></div><div class="related-content__author">By <a class="u-plain-link" href="/author/sammy-nickalls">Sammy Nickalls</a></div><div class="related-content__channel">Posted in <a href="/food">Food</a></div></li></ul></aside><p>Naturally, the registry will include special edition pizza packages tailored to the unique scenarios of pregnancy and parenthood. There’s “Sleeping Through The Night,” which presumably includes enough pizza to induce a food coma, “Dad’s Babysitting — AKA Mom’s Night Out” and “<a href="http://dominosbabyregistry.com/" rel="noopener noreferrer" target="_blank">Hormonal and Hangry</a>,” which likely comes with an odd assortment of judgment-free toppings and cheesy bread.&nbsp;</p><p>For those worried that a toothless infant would have to miss out on the bounteous blessings of the registry, fear not. Prospective parents can add for plenty of “essentials for your developing pizza lover,” like pizza-themed onesies, pepperoni moccasins, and other cheesy apparel to their wish list. And for those wishing to turn their baby shower into a pizza party, the registry includes supplies like pizza wrapping paper, invitations, and a “<a href="http://dominosbabyregistry.com/" rel="noopener noreferrer" target="_blank">diaper pizza</a>,” which, mercifully, is not intended to be edible.</p><div class="article-newsletter"><div class="article-newsletter__content flex"><div class="article-newsletter__form flex-item"><h3>Want More?</h3><h5>Our twice-a-week newsletter brings the <br /> best of Extra Crispy straight to you.</h5><form action="//extracrispy.us13.list-manage.com/subscribe/post?u=706ebcca1e8406049aea91905&id=105266e691" method="post" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate><input class="newsletter__field required" placeholder="Email" type="email" value="" name="EMAIL" id="mce-EMAIL"><input class="newsletter__field required" placeholder="Zip" type="text" value="" name="MMERGE1" id="mce-MMERGE1"><!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups--><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_706ebcca1e8406049aea91905_105266e691" tabindex="-1" value=""></div><input class="newsletter__submit" type="submit" value="submit" name="subscribe"></form></div><div class="article-newsletter__image flex-item" itemprop="image"></div></div></div><p>It might seem like a ridiculous concept. But pregnancy and parenthood are challenging enough, and you’re going to want to (stress) eat a lot of pizza anyway. The least you can do is try and trick your friends and family into paying for it.&nbsp;</p></div></section><aside class="container__side flex-item" id="js-sticky-ad-siderail"><section class="most-popular brush-fill brush-fill--grey" id="js-sticky-ad-popular"><h2 class="most-popular__heading section-heading">Most Popular</h2><div class="flex"><article class="post-preview post-preview--popular flex-item"><a href="/food/4488/the-third-date-egg-scramble"><div class="post-preview__image" style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F11%2Fthird-date-scramble.jpg%3Fquality%3D85');"><div class="post-preview__image-caption post-preview__image-caption--bottom-left post-preview__image-caption--popular"><span class="category-tag brush-stroke brush-stroke--black">Recipes</span></div></div><h3 class="post-preview__title post-preview__title--popular">The Third Date Egg Scramble</h3></a><div class="post-preview__meta"><a class="post-preview__author" href="/author/kate-welsh">Kate Welsh</a> </a><time class="post-preview__date"  datetime="2017-11-29">November 29, 2017</time></div></article><div class="post-preview post-preview--popular flex-item "><div class="ad native-ad" data-ad-type="nativeAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></div></div></section><div id="js-sticky-ad" class="ad ad--sticky" data-ad-type="stickyAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></aside></div></article><footer class="container flex"><section class="read-more container__main flex-item"><h2 class="read-more__heading brush-fill brush-fill--black">More to Read</h2><section class="container"><div class="flex flex--no-gutter"><article class="post-preview post-preview--small flex-item "><a href="/food/4468/30-ways-to-eat-fried-eggs"><div class="post-preview__image post-preview__image--small"style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F11%2Fbacon_edited_110417_2500x1500.jpg%3Fquality%3D85')"><div class="post-preview__image-caption post-preview__image-caption--centered"><span class="category-tag brush-stroke brush-stroke--yellow">Eggs</span></div></div><h2 class="post-preview__title post-preview__title--small">30 Ways to Eat Fried Eggs</h2></a><div class="post-preview__meta post-preview__meta--small"><a class="post-preview__author" href="/author/ali-slagle">Ali Slagle</a><time class="post-preview__date"  datetime="2017-11-27">November 27, 2017</time></div></article><div class="post-preview post-preview--small flex-item "><div class="ad native-ad" data-ad-type="nativeAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></div><article class="post-preview post-preview--small flex-item "><a href="/culture/4492/dominos-now-offers-a-baby-registry"><div class="post-preview__image post-preview__image--small"style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F11%2Fdominos-pizza-baby-shower.jpg%3Fquality%3D85')"><div class="post-preview__image-caption post-preview__image-caption--centered"><span class="category-tag brush-stroke brush-stroke--yellow">Fast Food</span></div></div><h2 class="post-preview__title post-preview__title--small">Domino&rsquo;s Now Offers a Baby Registry</h2></a><div class="post-preview__meta post-preview__meta--small"><a class="post-preview__author" href="/author/tim-nelson">Tim Nelson</a><time class="post-preview__date"  datetime="2017-11-30">November 30, 2017</time></div></article><article class="post-preview post-preview--small flex-item "><a href="/food/4490/panettone-french-toast"><div class="post-preview__image post-preview__image--small"style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F11%2Fpanettone-french-toast1.jpg%3Fquality%3D85')"><div class="post-preview__image-caption post-preview__image-caption--centered"><span class="category-tag brush-stroke brush-stroke--yellow">Bread</span></div></div><h2 class="post-preview__title post-preview__title--small">Here&rsquo;s What to Do with That Loaf of Panettone on Your Counter</h2></a><div class="post-preview__meta post-preview__meta--small"><a class="post-preview__author" href="/author/rebecca-firkser">Rebecca Firkser</a><time class="post-preview__date"  datetime="2017-11-30">November 30, 2017</time></div></article></div></section></section><aside class="container__side flex-item"></aside></footer><div class="container"><div class="ad ad--wide" data-ad-type="wideAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></div></main><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="container"><ul class="site-footer__links"><li class="site-footer__link"><a href="/the-team">The Extra Crispy Team</a></li><li class="site-footer__link"><a href="https://subscription.time.com/storefront/privacy/extracrispy/generic_privacy_new.html?dnp-source=E">Privacy Policy</a></li><li class="site-footer__link"><a href="https://subscription.time.com/storefront/privacy/extracrispy/generic_privacy_new.html?dnp-source=I#california">Your California Privacy Rights</a></li><li class="site-footer__link"><a href="https://subscription.time.com/storefront/privacy/extracrispy/privacy_terms_service.html">Terms of Service</a></li><li class="site-footer__link"><a href="http://subscription-assets.timeinc.com/prod/assets/themes/magazines/default/template-resources/html/legal/ti-corp-behavioral.html">Ad Choices</a></li><li class="site-footer__link"><a href="http://www.extracrispy.com/culture/185/how-to-pitch-extra-crispy">Submissions</a></li><li class="site-footer__link"><a href="mailto:submissions@extracrispy.com">Contact Us</a></li><li class="site-footer__link"><a href="/newsletter" target="_blank">Newsletter Signup</a></li><li class="site-footer__link"><a href="/advertise-with-us" target="_blank">Advertise With Us</a></li></ul>&copy; <script>document.write(new Date().getFullYear());</script> <span itemprop="copyrightHolder">Time Inc. All Rights Reserved. Extra Crispy is part of the Time Inc. Food Collection and the Time Inc. Lifestyle Network. EXTRA CRISPY is a registered trademark of Vertical Media Solutions Inc.</span></div></footer><script src="https://d1m8bioeteo0b4.cloudfront.net/prod/scripts.js?v=351d8c4"></script><script type="text/javascript">var isMobile = (window.viewportWidth <= 840);var isHomepage = (adParams.zone === 'homepage');var isArticle = (adParams.ptype === 'content');var isChannel = (document.querySelector('.category-page__header.is-channel'));var nativeKey = '';if (isMobile && isHomepage) {nativeKey = 'umdZVVK1uCawa2LnPQBCdjdR';}else if (isMobile && isChannel) {nativeKey = 'rmQqE4LTVVe6UJ22B1aXPkvn';}else if (isMobile && isArticle) {nativeKey = 'VXBP7NbkExooBxWUkgQQbhRx';}else if (isMobile) {nativeKey = '6cd6m52qWM1H4epjzj2jV7zF';}else if (isHomepage) {nativeKey = '7nTq5Wsis2NSFNHNhMXMuybK';}else if (isArticle) {nativeKey = 'QSZdnZ3i6LqdJLjmNvEc9Aai';}else if (isChannel) {nativeKey = 'NXtFAbBwiMaY3id4uVBDXQgF';}else {nativeKey = 'yVqqdzh6ehxuQvKC6YbQn7cX';}adSlotTargets.strnativekey = nativeKey;</script><script async src="//native.sharethrough.com/assets/sfp.js"></script><script async type="text/javascript" src="https://tia.timeinc.net/timeinc/tia.min.js"></script><script type='text/javascript'>var _sf_async_config = _sf_async_config || {};/** CONFIGURATION START **/_sf_async_config.sections = 'Culture';_sf_async_config.authors = 'Tim Nelson';/** CONFIGURATION END **/(function(){function loadChartbeat() {window._sf_endpt=(new Date()).getTime(); var e = document.createElement('script'); e.setAttribute('language', 'javascript'); e.setAttribute('type', 'text/javascript'); e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js'); document.body.appendChild(e);}var oldonload = window.onload;window.onload = (typeof window.onload != 'function') ?loadChartbeat : function() {oldonload(); loadChartbeat();};})();</script></body></html>