<!DOCTYPE html><html lang="en-US" itemscope itemtype="http://schema.org/Article"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no"><title>This Is Your Crepe-Making Pep Talk | Extra Crispy</title><meta name="description" content="I love crepes, but I don&#39;t love spending $10 on a paper-thin pancake filled with two slices of deli ham and a child-sized fistful of lethargic fre..."><meta name="keywords" content="breakfast, brunch, food, food news, eggs, coffee, bacon, morning culture, cooking hacks, recipe hacks, pancakes, waffles, cereal, recipe ideas, breakfast ideas, brunch ideas, cooking breakfast, cafe culture"><meta name="news_keywords" content="breakfast, brunch, food, food news, eggs, coffee, bacon, morning culture, cooking hacks, recipe hacks, pancakes, waffles, cereal, recipe ideas, breakfast ideas, brunch ideas, cooking breakfast, cafe culture"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@extracrispy"><meta name="p:domain_verify" content="014366745e9b889c962b312f25007c9c"/><meta property="fb:pages" content="875710779209860"><meta property="og:locale" content="en_US"><meta property="og:site_name" content="Extra Crispy"><meta property="og:type" content="article"><meta property="og:title" content="This Is Your Crepe-Making Pep Talk"><meta property="og:description" content="I love crepes, but I don&#39;t love spending $10 on a paper-thin pancake filled with two slices of deli ham and a child-sized fistful of lethargic fre..."><meta property="og:image" content="https://timedotcom.files.wordpress.com/2017/07/crepe-stack-hero.jpg?quality=85"><meta property="og:image:width" content="1024"><meta property="og:image:height" content="614"><meta name="author" content="Allison Robicelli"><meta property="article:author" content="Allison Robicelli"><meta property="article:publisher" content="https://www.facebook.com/extracrispy"><meta property="article:published_time" content="2017-07-07"><meta property="article:section" content="Food"><meta property="article:tag" content="Crepes"><meta property="article:tag" content="Cooking Techniques"><meta property="article:tag" content="How To"><meta property="og:url" content="http://www.extracrispy.com/food/3377/this-is-your-crepe-making-pep-talk"><link rel="canonical" href="http://www.extracrispy.com/food/3377/this-is-your-crepe-making-pep-talk"><link rel="amphtml" href="http://amp.timeinc.net/extracrispy/food/3377/this-is-your-crepe-making-pep-talk?source=dam"><link rel="stylesheet" href="https://d1m8bioeteo0b4.cloudfront.net/prod/styles.css?v=99729ad"><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:400,700|Fugaz+One"><link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-57x57.png"><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-114x114.png"><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-72x72.png"><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-144x144.png"><link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-60x60.png"><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d1m8bioeteo0b4.cloudfront.net/apple-touch-icon-120x120.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="/https://d1m8bioeteo0b4.cloudfront.netapple-touch-icon-76x76.png"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-96x96.png" sizes="96x96"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-32x32.png" sizes="32x32"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-16x16.png" sizes="16x16"><link rel="icon" type="image/png" href="https://d1m8bioeteo0b4.cloudfront.net/favicon-128.png" sizes="128x128"><meta name="application-name" content="Extra Crispy"><meta name="msapplication-TileColor" content="#FFE240"><meta name="msapplication-TileImage" content="https://d1m8bioeteo0b4.cloudfront.net/mstile-144x144.png"><meta name="msapplication-square70x70logo" content="https://d1m8bioeteo0b4.cloudfront.net/mstile-70x70.png"><meta itemprop="keywords" content="breakfast, brunch, food, food news, eggs, coffee, bacon, morning culture, cooking hacks, recipe hacks, pancakes, waffles, cereal, recipe ideas, breakfast ideas, brunch ideas, cooking breakfast, cafe culture"><meta itemprop="description" content="I love crepes, but I don&#39;t love spending $10 on a paper-thin pancake filled with two slices of deli ham and a child-sized fistful of lethargic fre..."><meta itemprop="url" content="http://www.extracrispy.com/food/3377/this-is-your-crepe-making-pep-talk"><span itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.extracrispy.com/images/site-logo.png"></span><meta itemprop="name" content="Extra Crispy"><meta itemprop="url" content="http://www.extracrispy.com"></span><span itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://timedotcom.files.wordpress.com/2017/07/crepe-stack-hero.jpg?quality=85"><meta itemprop="height" content="100%"><meta itemprop="width" content="100%"></span><meta itemprop="author" content="Allison Robicelli"><script>var adSlotTargets = {};var adParams = {"ptype" : "content","zone" : "Food".replace(/\(|\)/g, '').replace(/\s+/g, '-').toLowerCase(),"ch" : "Food".replace(/\(|\)/g, '').replace(/\s+/g, '-').toLowerCase(),"sch" : "Crepes,Cooking Techniques,How To".replace(/\(|\)/g, '').replace(/, /g, ',').replace(/\s+/g, '-').toLowerCase().split(',')};adSlotTargets.ptype = adParams.ptype;adSlotTargets.ch = adParams.ch;adSlotTargets.aid = "3377";adSlotTargets.ctype = "article";if (adSlotTargets.ctype === "video" || adSlotTargets.ctype === "gallery") {adSlotTargets.etype = adSlotTargets.ctype;}adSlotTargets.sch = adParams.sch;if (adParams.ptype === "channel" && adParams.zone !== "homepage") {adParams.zone += "/main";adSlotTargets.ptype = "channel";adSlotTargets.ctype = "main";};var TIA_CONFIG = {setGlobalTargeting: adSlotTargets,sitename: "extracrispy",zone: adParams.zone,realvu: true};window.time_dfp = window.time_dfp || [];window.time_dfp.push(function() {window.time_dfp.init(TIA_CONFIG);});</script><script type="text/javascript">__reach_config = {pid: '5734de2b736b79b1e9001a74',title: 'This Is Your Crepe-Making Pep Talk',url: 'http://www.extracrispy.com/food/3377/this-is-your-crepe-making-pep-talk',date: '2017-07-07',authors: ['Allison Robicelli'],channels: ['Food'],tags: "Crepes,Cooking Techniques,How To".split(","),ignore_errors: false};(function(){var s = document.createElement('script');s.async = true;s.type = 'text/javascript';s.src = document.location.protocol + '//d8rk54i4mohrb.cloudfront.net/js/reach.js';(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(s);})();</script><script type="text/javascript">var _sf_async_config = _sf_async_config || {};/** CONFIGURATION START **/_sf_async_config.uid = 63293;// ACCOUNT NUMBER_sf_async_config.domain = extracrispy.com;// DOMAIN_sf_async_config.flickerControl = false;_sf_async_config.useCanonical = true;/** CONFIGURATION END **/var _sf_startpt = (new Date()).getTime();</script><script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script><script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod? n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '1545947199043709');fbq('track', "PageView");</script><noscript><img height="1" width="1" style="display:none"src="https://www.facebook.com/tr?id=1545947199043709&ev=PageView&noscript=1"/></noscript><!-- Time Inc - Segment --><script type="text/javascript">!function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","reset","group","track","ready","alias","debug","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="4.0.0";analytics.load("YYHbYKtAgp7bXHASvGPebuFmlNI0Z2ME");window.segment = {"contentAuthorName":"Allison Robicelli","contentCmsCategory":"Food","contentCmsId":"3377","contentCmsSubCategory":"crepes|cooking techniques|how to","contentCmsTerms":["Food","crepes","cooking techniques","how to"],"contentCmsTags":null,"contentContributorName":null,"contentFeaturedImage":"https://timedotcom.files.wordpress.com/2017/07/crepe-stack-hero.jpg?quality=85","contentHeadline":"This Is Your Crepe-Making Pep Talk","contentModifiedDate":"2017-07-07T20:07:39Z","contentPublishedDate":"2017-07-07T20:07:39Z","contentShownOnPlatform":"own","contentType":"article","path":"/food/3377/this-is-your-crepe-making-pep-talk","search":null,"timeIncApplication":"wordpress","timeIncBrand":"extracrispy.com","title":"This Is Your Crepe-Making Pep Talk","url":"http://www.extracrispy.com/food/3377/this-is-your-crepe-making-pep-talk"};window.analytics.page(window.segment);}}();</script></head><body class="bg-food" style="background-image: url('https://d1m8bioeteo0b4.cloudfront.net/images/bg-food-left-3.jpg'), url('https://d1m8bioeteo0b4.cloudfront.net/images/bg-food-right-1.jpg')"><script type="text/javascript">var siteDisplayFormat = "mobile";window.viewportWidth = Math.max(document.documentElement.clientWidth, window.innerWidth || 0);if (window.viewportWidth > 840)  {siteDisplayFormat = "desktop";}var utag_data = {channel: "extracrispy",page_name: "This Is Your Crepe-Making Pep Talk".replace(/&[\S]{0,7};/ig, ""),site_display_format: siteDisplayFormat,template_type: "article",site_section1: "Food",};utag_data.site_section2 = "Crepes";utag_data.content_id = "3377";utag_data.author_name = "Allison Robicelli";utag_data.publish_date = "2017-07-07";</script><script type="text/javascript">(function(a,b,c,d){a='//tags.tiqcdn.com/utag/timeinc/extracrispy.com/prod/utag.js';b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);})();</script><header id="js-site-header" class="site-header"><div class="flex flex--no-wrap flex--stretch flex--middle container"><a class="site-header__logo" href="/"><img class="site-nav__logo" src="/images/site-logo.png" width="140" height="85" alt="Extra Crispy"></a><div class="responsive-spacer"></div><div class="responsive-nav-toggle js-dropdown"><span class="responsive-nav-toggle__text">Menu</span><i class="icon icon-dropdown dropdown-icon"></i><nav class="responsive-nav dropdown-popout"><div class="responsive-nav__arrow"></div><div class="responsive-nav__wrapper"><ul class="site-nav"><li class="site-nav__item"><a class="site-nav__link" href="/culture">Culture</a></li><li class="site-nav__item"><a class="site-nav__link" href="/drinks">Drinks</a></li><li class="site-nav__item"><a class="site-nav__link" href="/food">Food</a></li><li class="site-nav__item"><a class="site-nav__link" href="/video">Video</a></li><li class="site-nav__dropdown-toggle site-nav__item js-dropdown"><i class="icon icon-dropdown dropdown-icon"></i><ul class="site-nav__dropdown dropdown-popout"><div class="site-nav__dropdown-arrow"></div><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/recipes">Recipes</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/cheese">Cheese</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/travel">Travel</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/booze">Booze</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/hacks">Hacks</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/the-a-m">The A.M.</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/coffee">Coffee</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/eggs">Eggs</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/butter">Butter</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/spring-breakfast">Spring Break(fast)</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/bacon">Bacon</a></li><li class="site-nav__item"><a class="site-nav__dropdown-link" href="/healthy">Healthy</a></li></ul></li></ul><ul class="site-social"><li class="site-social__item"><a class="site-social__newsletter" href="/newsletter" target="_blank">Newsletter Signup</a></li><li class="site-social__item"><a class="icon icon-facebook" href="https://www.facebook.com/extracrispy" title="Facebook" aria-label="Facebook" target="_blank"></a><a class="icon icon-twitter" href="https://www.twitter.com/extracrispy" title="Twitter" aria-label="Twitter" target="_blank"></a><a class="icon icon-instagram" href="https://www.instagram.com/extracrispy" title="Instagram" aria-label="Instagram" target="_blank"></a><a class="icon icon-pinterest" href="https://www.pinterest.com/itsextracrispy" title="Pinterest" aria-label="Pinterest" target="_blank"></a></li></ul></div></nav></div><form class="js-search site-search" action="\search" method="GET"><label for="search" class="u-off-screen">Search</label><input id="search" class="js-search-input site-search__input" type="text" name="q" placeholder="Search"><button class="js-search-toggle site-search__submit button icon icon-search" type="submit" title="Submit" aria-label="Submit"></button></form></div></header><main><article itemprop="mainEntityOfPage"><header class="article-header "><div class="article-header__hero-image " style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=1920&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F07%2Fcrepe-stack-hero.jpg%3Fquality%3D85');"></div><div class="article-header__overlay"><div class="article-header__flex container"><div class="article-header__hero-credit">Photo by monkeybusinessimages via Getty Images</div><div class="article-header__pinterest-wrapper"><a class="js-tealium-social-share pinterest-pin-it-button icon icon-pinterest"href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fextra.cr%2F2syY04O&amp;description=This%20Is%20Your%20Crepe-Making%20Pep%20Talk&amp;media=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F07%2Fcrepe-stack-hero.jpg%3Fquality%3D85"data-social="pinterest"data-pin-do="buttonPin"data-pin-custom="true"target="_blank"rel="nofollow"title="Share on Pinterest"aria-label="Share on Pinterest"></a></div><div class="article-header__hero-text"><h1 class="article-header__title brush-fill brush-fill--white" itemprop="headline">This Is Your Crepe-Making Pep Talk</h1><p class="article-header__subtitle brush-fill brush-fill--black">Cut the excuses, make the crepe</p></div></div></div></header><div class="container flex" id="js-sticky-ad-container"><section class="container__main flex-item"><div class="article-meta"><a class="article-meta__author" href="/author/allison-robicelli">Allison Robicelli</a> <time class="article-meta__date" datetime="2017-07-07" itemprop="datePublished">July 07, 2017</time><span content="July 07, 2017" itemprop="dateModified"></span><ul class="article-meta__categories"><li class="article-meta__category category-tag"><a class="brush-stroke brush-stroke--yellow" href="/food">Food</a></li><li class="article-meta__category category-tag"><a class="brush-stroke brush-stroke--yellow" href="/crepes">Crepes</a></li><li class="article-meta__category category-tag"><a class="brush-stroke brush-stroke--yellow" href="/cooking-techniques">Cooking Techniques</a></li><li class="article-meta__category category-tag"><a class="brush-stroke brush-stroke--yellow" href="/how-to">How To</a></li></ul><ul class="article-meta__socials"><li class="article-meta__social"><a class="js-tealium-social-share icon icon-twitter"data-social="twitter"href="http://twitter.com/intent/tweet?text=This%20Is%20Your%20Crepe-Making%20Pep%20Talk&amp;via=extracrispy&amp;url=http%3A%2F%2Fextra.cr%2F2syP5R1"target="_blank" rel="nofollow"title="Share on Twitter" aria-label="Share on Twitter"></a></li><li class="article-meta__social"><a class="js-tealium-social-share icon icon-facebook"data-social="facebook"href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fextra.cr%2F2syP6o3"target="_blank" rel="nofollow"title="Share on Facebook" aria-label="Share on Facebook"></a></li><li class="article-meta__social"><a class="js-tealium-social-share icon icon-pinterest"data-social="pinterest"data-pin-do="buttonPin"data-pin-custom="true"href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fextra.cr%2F2syY04O&amp;description=This%20Is%20Your%20Crepe-Making%20Pep%20Talk&amp;media=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F07%2Fcrepe-stack-hero.jpg%3Fquality%3D85"target="_blank" rel="nofollow"title="Share on Pinterest" aria-label="Share on Pinterest"></a></li><li class="article-meta__social"><a class="icon icon-email"href="mailto:?subject=This%20Is%20Your%20Crepe-Making%20Pep%20Talk&amp;body=http://www.extracrispy.com/food/3377/this-is-your-crepe-making-pep-talk?xid=emailshare"target="_blank" rel="nofollow"title="Share via Email" aria-label="Share via Email"></a></li></ul></div><div class="article-body" itemprop="articleBody"><p>I love crepes, but I don’t love spending $10 on a paper-thin pancake filled with two slices of deli ham and a child-sized fistful of lethargic fresh spinach. (Okay, I’m lying: replace ham with “<a href="https://www.theyellowtable.com/recipes/best-nutella-crepe-recipe" rel="noopener noreferrer" target="_blank">Nutella</a>” and spinach with “extra whipped cream.”) A single <a href="http://www.extracrispy.com/food/770/pretty-up-any-crepe-recipe-with-edible-flowers" rel="noopener noreferrer" target="_blank">crepe</a> will satiate your hunger exactly zero percent, which is why you need to eat at least five in a sitting. And since blowing your paycheck every week on an out-of-control <a href="http://www.foodandwine.com/slideshows/sweet-crepe-recipes" rel="noopener noreferrer" target="_blank">crepe</a> habit is completely ridiculous, you should probably learn to make your own. Remember: If a 16-year-old working part time at a <a href="http://www.epicurious.com/recipes/food/views/basic-crepes-1220" rel="noopener noreferrer" target="_blank">crepe</a> stand in the mall can do it, so can you.</p><h2>Use instant flour</h2><p>If you’ve dipped your toes into the ocean of <a href="http://www.thekitchn.com/perfect-crepes-5-tips-from-suz-127425" rel="noopener noreferrer" target="_blank">crepe-making</a> before, you know that you’re supposed to let your batter rest for at least an hour—preferably overnight—to let the flour “hydrate.” For those unfamiliar with the term, when water is added to flour it unlocks a protein you’ve most definitely heard of before: gluten. Picture gluten as one of those dry fettuccine nests you see in the fancy pasta section of the supermarket. When it soaks up water, it gets soft and loosens up, eventually unravelling into long strands. Letting your <a href="https://www.theguardian.com/lifeandstyle/2002/feb/24/foodanddrink.recipes" rel="noopener noreferrer" target="_blank">crepe batter hydrate</a> means you can make paper-thin pancakes that won’t fall apart, but will also not be tough and chewy. However, it takes some time for this magic to happen, and I for one am not all about waiting.&nbsp;</p><aside class="related-content"><ul class="related-content__list flex flex--no-wrap"><li class="related-content__item flex-item"><div class="ad native-ad" data-ad-type="nativeAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></li><li class="related-content__item flex-item"><div class="related-content__title"><a href="/video/832/this-rainbow-crepe-cake-is-everything-you-didnt-know-you-needed" >This Rainbow Crepe Cake Is Everything You Didn&rsquo;t Know You Needed</a></div><div class="related-content__author">By <a class="u-plain-link" href="/author/jiselle-basile">Jiselle Basile</a></div><div class="related-content__channel">Posted in <a href="/video">Video</a></div></li><li class="related-content__item flex-item"><div class="related-content__title"><a href="/food/770/pretty-up-any-crepe-recipe-with-edible-flowers" >Pretty Up Any Crepe Recipe with Edible Flowers</a></div><div class="related-content__author">By <a class="u-plain-link" href="/author/jiselle-basile">Jiselle Basile</a></div><div class="related-content__channel">Posted in <a href="/food">Food</a></div></li></ul></aside><p>Thanks to the wonders of the modern age, we need to wait no more! Next time you’re at the supermarket pick up a can of instant flour—the stuff you usually only buy at Thanksgiving to use for gravy. It’s used for sauces because it’s <em>pregelatinized</em>:<strong>&nbsp;</strong>partially cooked, then dried and ground into a fine powder. Not only does it dissolve quickly in liquids without clumping, but those proteins hydrate in a fraction of the time since they’re already halfway there. Swap out your usual flour for instant, and you’ll be ready to go in about ten minutes.</p><div class="video__wrapper"><video data-viewplay="true"  data-video-id="5123005831001" data-account="4863540596001" data-player="default" data-embed="default" class="video-js"  controls playsinline></video></div><h2>Use a nonstick pan</h2><p>You know these things are going to stick like mad and it’s going to drive you into a dark, dark place. The nonstick pan is your friend. Also make sure you keep it greased: Ghee is best, but a light touch of cooking spray is also good. Regular butter will end up burning, so don’t bother with it.</p><h2>Control your heat</h2><p>You want it to be on medium-low. I know you’re excited and want to get to eating right away, but slow and steady wins this race.</p><h2>Don’t worry about the first one</h2><p>The first one is always a disaster. No one knows the science behind it. It just is and we’ve all learned to live with it. Your second one might be a mess, too, but that’s just because you don’t know what you’re doing. You’ll eventually find your groove and it will be nothing but smooth sailing. Just learn to forgive yourself and keep forging ahead.&nbsp;</p><h2>Flipping ain’t that bad</h2><p>Speaking of disasters, you’re going to botch the flipping a few times, but I pinky-swear you’re going to get the hang of things. Keep your eye on edges of the crepe; you’re ready to flip when they curl up a bit. Use a small spatula or the tip of a butter knife to gently lift an edge, then grab it with your fingers. Lift it up and gently lay it down on the other side, and cook for another 30 seconds or so. Slide it right out and keep repeating until all your batter is used up.&nbsp;</p></div></section><aside class="container__side flex-item" id="js-sticky-ad-siderail"><section class="most-popular brush-fill brush-fill--grey" id="js-sticky-ad-popular"><h2 class="most-popular__heading section-heading">Most Popular</h2><div class="flex"><article class="post-preview post-preview--popular flex-item"><a href="/food/3333/whats-the-difference-between-black-and-white-watermelon-seeds"><div class="post-preview__image" style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F07%2Fwatermelon-seeds-white-black-hero-getty.jpg%3Fquality%3D85');"><div class="post-preview__image-caption post-preview__image-caption--bottom-left post-preview__image-caption--popular"><span class="category-tag brush-stroke brush-stroke--black">Fruit</span></div></div><h3 class="post-preview__title post-preview__title--popular">What&#039;s the Difference Between Black and White Watermelon Seeds?</h3></a><div class="post-preview__meta"><a class="post-preview__author" href="/author/maxine-builder">Maxine Builder</a> </a><time class="post-preview__date"  datetime="2017-07-05">July 05, 2017</time></div></article><div class="post-preview post-preview--popular flex-item "><div class="ad native-ad" data-ad-type="nativeAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></div></div></section><div id="js-sticky-ad" class="ad ad--sticky" data-ad-type="stickyAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></aside></div></article><footer class="container flex"><section class="read-more container__main flex-item"><h2 class="read-more__heading brush-fill brush-fill--black">More to Read</h2><section class="container"><div class="flex flex--no-gutter"><article class="post-preview post-preview--small flex-item "><a href="/drinks/3338/how-starbucks-got-its-literary-name"><div class="post-preview__image post-preview__image--small"style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F07%2Fzhang-peng-contributor.jpg%3Fquality%3D85')"><div class="post-preview__image-caption post-preview__image-caption--centered"><span class="category-tag brush-stroke brush-stroke--yellow">Coffee</span></div></div><h2 class="post-preview__title post-preview__title--small">How Starbucks Got Its Literary Name</h2></a><div class="post-preview__meta post-preview__meta--small"><a class="post-preview__author" href="/author/rebecca-firkser">Rebecca Firkser</a><time class="post-preview__date"  datetime="2017-07-05">July 05, 2017</time></div></article><div class="post-preview post-preview--small flex-item "><div class="ad native-ad" data-ad-type="nativeAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></div><article class="post-preview post-preview--small flex-item "><a href="/video/3305/3-in-1-breakfast-machine-challenge-isaac-toups"><div class="post-preview__image post-preview__image--small"style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F06%2Fisaac-toups-3-in-1-challenge-hero1.jpg%3Fquality%3D85')"><div class="post-preview__image-caption post-preview__image-caption--centered"><span class="category-tag brush-stroke brush-stroke--yellow">Gear</span></div></div><h2 class="post-preview__title post-preview__title--small">3-in-1 Breakfast Machine Challenge: Isaac Toups <i class="post-preview__video-icon icon icon-video"></i></h2></a><div class="post-preview__meta post-preview__meta--small"><a class="post-preview__author" href="/author/extra-crispy-staff">Extra Crispy Staff</a><time class="post-preview__date"  datetime="2017-06-29">June 29, 2017</time></div></article><article class="post-preview post-preview--small flex-item "><a href="/food/3332/everything-you-ever-cared-to-know-about-the-different-kinds-of-spatulas"><div class="post-preview__image post-preview__image--small"style="background-image: url('http://imagesvc.timeincapp.com/?q=60&amp;w=500&amp;url=https%3A%2F%2Ftimedotcom.files.wordpress.com%2F2017%2F07%2Fspatulas.jpg%3Fquality%3D85')"><div class="post-preview__image-caption post-preview__image-caption--centered"><span class="category-tag brush-stroke brush-stroke--yellow">Gear</span></div></div><h2 class="post-preview__title post-preview__title--small">Everything You Ever Cared to Know About the Different Kinds of Spatulas</h2></a><div class="post-preview__meta post-preview__meta--small"><a class="post-preview__author" href="/author/allison-robicelli">Allison Robicelli</a><time class="post-preview__date"  datetime="2017-07-05">July 05, 2017</time></div></article></div></section></section><aside class="container__side flex-item"></aside></footer><div class="container"><div class="ad ad--wide" data-ad-type="wideAd" itemscope itemtype="http://schema.org/WPAdBlock"></div></div></main><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="container"><ul class="site-footer__links"><li class="site-footer__link"><a href="/the-team">The Extra Crispy Team</a></li><li class="site-footer__link"><a href="https://subscription.time.com/storefront/privacy/extracrispy/generic_privacy_new.html?dnp-source=E">Privacy Policy</a></li><li class="site-footer__link"><a href="https://subscription.time.com/storefront/privacy/extracrispy/generic_privacy_new.html?dnp-source=I#california">Your California Privacy Rights</a></li><li class="site-footer__link"><a href="https://subscription.time.com/storefront/privacy/extracrispy/privacy_terms_service.html">Terms of Service</a></li><li class="site-footer__link"><a href="http://subscription-assets.timeinc.com/prod/assets/themes/magazines/default/template-resources/html/legal/ti-corp-behavioral.html">Ad Choices</a></li><li class="site-footer__link"><a href="http://www.extracrispy.com/culture/185/how-to-pitch-extra-crispy">Submissions</a></li><li class="site-footer__link"><a href="mailto:submissions@extracrispy.com">Contact Us</a></li><li class="site-footer__link"><a href="/newsletter" target="_blank">Newsletter Signup</a></li></ul>&copy; <script>document.write(new Date().getFullYear());</script> <span itemprop="copyrightHolder">Time Inc. All Rights Reserved. Extra Crispy is part of the Time Inc. Food Collection and the Time Inc. Lifestyle Network. EXTRA CRISPY is a registered trademark of Vertical Media Solutions Inc.</span></div></footer><script src="https://d1m8bioeteo0b4.cloudfront.net/prod/scripts.js?v=99729ad"></script><script async src="//cdn.video.timeinc.com/jumpstart/v1/js/jumpstart.min.js"></script><script type="text/javascript">var isMobile = (window.viewportWidth <= 840);var isHomepage = (adParams.zone === 'homepage');var isArticle = (adParams.ptype === 'content');var isChannel = (document.querySelector('.category-page__header.is-channel'));var nativeKey = '';if (isMobile && isHomepage) {nativeKey = 'umdZVVK1uCawa2LnPQBCdjdR';}else if (isMobile && isChannel) {nativeKey = 'rmQqE4LTVVe6UJ22B1aXPkvn';}else if (isMobile && isArticle) {nativeKey = 'VXBP7NbkExooBxWUkgQQbhRx';}else if (isMobile) {nativeKey = '6cd6m52qWM1H4epjzj2jV7zF';}else if (isHomepage) {nativeKey = '7nTq5Wsis2NSFNHNhMXMuybK';}else if (isArticle) {nativeKey = 'QSZdnZ3i6LqdJLjmNvEc9Aai';}else if (isChannel) {nativeKey = 'NXtFAbBwiMaY3id4uVBDXQgF';}else {nativeKey = 'yVqqdzh6ehxuQvKC6YbQn7cX';}adSlotTargets.strnativekey = nativeKey;</script><script async src="//native.sharethrough.com/assets/sfp.js"></script><script async type="text/javascript" src="https://tia.timeinc.net/timeinc/tia.min.js"></script><script type='text/javascript'>var _sf_async_config = _sf_async_config || {};/** CONFIGURATION START **/_sf_async_config.sections = 'Food';_sf_async_config.authors = 'Allison Robicelli';/** CONFIGURATION END **/(function(){function loadChartbeat() {window._sf_endpt=(new Date()).getTime(); var e = document.createElement('script'); e.setAttribute('language', 'javascript'); e.setAttribute('type', 'text/javascript'); e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js'); document.body.appendChild(e);}var oldonload = window.onload;window.onload = (typeof window.onload != 'function') ?loadChartbeat : function() {oldonload(); loadChartbeat();};})();</script></body></html>